رتبه موضوع:
  • 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
نصب فریمورک یی 2 (حل شد)
#1
سلام
من فریمورک یی 2 رو دانلود کردم و به همون روش نصب yii1.1 نصبش کردم  و در path آدرس :
C:\xampp\yii2\frontend;  را قرار دادم
ولی هنگامی که میزنم

[عکس: wa4w_r3ill4lt_-_copy_(3)_-_copy.gif]

من هنوز فریمورک yii1.1 رو هم دارم
میخوام بدونم برای نصب 2 باید چکار کرد ؟
این هم از صفحه اصلی :

[عکس: f92n9ifqskph.gif]

ولی وقتی requirement.php رو باز میکنم میگه امکانات حداقل رو داری
انگار که نیستی ، چو هستی خوش باش
حکیم عمر خیام
پاسخ
تشکر شده توسط:
#2
برو تو پوشه ی config بعدش فایل web.php رو باز کن و cookieValidationKey رو یه مقدار دلخواه بده

'request' => [
    // !!! insert a secret key in the following (if it is empty) - this is required by cookie validation
    'cookieValidationKey' => 'ncis.ir',
]
پاسخ
تشکر شده توسط: tabesh
#3
ممنونم دوست عزیز
این درست شد اما حالا میخوام یک پروژه ایجاد کنم عین hello Word . چطوری باید یک پروژه جدید با yii2 درست کرد ؟ دستورش چیه ؟
انگار که نیستی ، چو هستی خوش باش
حکیم عمر خیام
پاسخ
تشکر شده توسط:
#4
دیگه اون مدلی نیست. باید با کامپوزر بسازین:
composer create-project yiisoft/yii2-app-basic helloworld 2.0.6
پاسخ
تشکر شده توسط: tabesh
#5
خیلی ممنون از راهنماییتون  فایل ایجاد شد اما دو مورد پیش اومده :
هنگام ایجاد پروژه برایم problem1 اومده :

[عکس: 2uqr753i8iha.gif]

وقتی وارد پروژه میشوم :

[عکس: 19biidtpch5o.gif]
انگار که نیستی ، چو هستی خوش باش
حکیم عمر خیام
پاسخ
تشکر شده توسط:
#6
این رو هم بگم ، من فایل basic را در htdocs قرار دادم و آدرس C:\xampp\yii2\frontend; را هم از path حذف کردم
کجای کار مشکل داره ؟
انگار که نیستی ، چو هستی خوش باش
حکیم عمر خیام
پاسخ
تشکر شده توسط:
#7
موقع کار با کامپوزر ترجیحاً از پراکسی استفاده کنید. توی ایران برای کار با HTTPS مشکل داریم و پکتها دستکاری میشن و هش اونها عوض میشه.
پاسخ
تشکر شده توسط:
#8
با کریو وی پی ان هم کردم نشد ! همون ارور قبلی رو داد
حالا سوال :
2.0.6 چیه آخر helloworld نوشتید ؟
و اینکه چرا دانلود میکنه ؟ 1.1 راحت میساخت .
راهی نیست دانلود نکنه ؟ چند روزه نصبش کردم ولی نمیشه باهاش پروژه ساخت!!!
انگار که نیستی ، چو هستی خوش باش
حکیم عمر خیام
پاسخ
تشکر شده توسط:
#9
(26-09-1394، 03:46 ب.ظ)tabesh نوشته: با کریو وی پی ان هم کردم نشد ! همون ارور قبلی رو داد
حالا سوال :
2.0.6 چیه آخر helloworld نوشتید ؟
و اینکه چرا دانلود میکنه ؟ 1.1 راحت میساخت .
راهی نیست دانلود نکنه ؟ چند روزه نصبش کردم ولی نمیشه باهاش پروژه ساخت!!!

سوال 1 : مربوط به ورژن فریمورک هست که آخرین نسخه موجود 2.0.6 هستش .

سوال دوم هم بطوری کلی برای نصب با کامپوزر باید دستورات زیر رو اجرا کنین :

اول دستور زیر :
composer global require "fxp/composer-asset-plugin:~1.1.1"

و بعد دستور زیر :
composer create-project --prefer-dist yiisoft/yii2-app-basic helloworld

معمولا نیازی به وارد کردن نسخه فریمورک نیست خودش آخرین نسخه رو براتون نصب میکنه !

موفق باشین.
پاسخ
تشکر شده توسط:
#10
ضمناً کامپوزر اولین بار دانلود میکنه و بعد از اون اگه تغییر نکرده باشه (خودش چک میکنه)، از Cache میخونه.
پاسخ
تشکر شده توسط:
#11
میتونید از این آدرس: http://www.yiiframework.com/download

نسخه ZIP رو دریافت کنید و نصب کنید. فقط بعد از نصب باید توی فایل تنظیمات، cookieValidationKey رو مقداردهی کنید.
پاسخ
تشکر شده توسط:
#12
(26-09-1394، 06:33 ب.ظ)ADMIN نوشته: میتونید از این آدرس: http://www.yiiframework.com/download

نسخه ZIP رو دریافت کنید و نصب کنید. فقط بعد از نصب باید توی فایل تنظیمات، cookieValidationKey رو مقداردهی کنید.

 من خیلی وقته این کارو کردم و این رو هم مقدار دهی کردم
الان صفحه Congratulations! رو هم دارم .
 فقط میخوام بدونم چطوری پروژه های جدید درست کنم؟؟؟
انگار که نیستی ، چو هستی خوش باش
حکیم عمر خیام
پاسخ
تشکر شده توسط:
#13
هربار همین کار رو تکرار کنید. فایل ZIP رو باید extract کنید توی پوشه جدید. الان دیگه فریمورک همراه خود پروژه است و جدا نیست که براتون پروژه بسازه.
پاسخ
تشکر شده توسط: tabesh




کاربران در حال بازدید این موضوع: 1 مهمان