خطا‌‌ها‌ی زیر رخ داد:
Warning [2] preg_replace_callback(): Requires argument 2, 'mwsshcode_check("$1","$2")', to be a valid callback - Line: 197 - File: inc/plugins/mwsshcode.php PHP 7.3.4 (Linux)
File Line Function
[PHP]   errorHandler->error
/inc/plugins/mwsshcode.php 197 preg_replace_callback
/inc/class_plugins.php 139 mwsshcode_run
/inc/class_parser.php 187 pluginSystem->run_hooks
/inc/functions_post.php 721 postParser->parse_message
/showthread.php 1063 build_postbit
Warning [2] preg_replace_callback(): Requires argument 2, 'mwsshcode_check("$1","$2")', to be a valid callback - Line: 197 - File: inc/plugins/mwsshcode.php PHP 7.3.4 (Linux)
File Line Function
[PHP]   errorHandler->error
/inc/plugins/mwsshcode.php 197 preg_replace_callback
/inc/class_plugins.php 139 mwsshcode_run
/inc/class_parser.php 187 pluginSystem->run_hooks
/inc/functions_post.php 721 postParser->parse_message
/showthread.php 1063 build_postbit




رتبه موضوع:
  • 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
مشکل نصب نسخه 2
#1
سلام
من برای نصب از composer  استفاده کردم. دستور زیر رو 
کد:
composer create-project --prefer-dist yiisoft/yii2-app-basic yiibasic

نصب هم میشه ولی وقتی میرم تو پوشه /web اررور میده
کد:
Warning: require(C:\xampp\htdocs\yiibasic\web/../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\yiibasic\web\index.php on line 7

Fatal error: require(): Failed opening required 'C:\xampp\htdocs\yiibasic\web/../vendor/autoload.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\yiibasic\web\index.php on line 7

ممنون میشم راهنمایی کنید مشکلم در کجاست
پاسخ
تشکر شده توسط:
#2
مشکل بر طرف شد
دلیلش این بود که قبلش
composer global require "fxp/composer-asset-plugin:1.0.0"
باید نصب میشد
پاسخ
تشکر شده توسط:




کاربران در حال بازدید این موضوع: 1 مهمان