رتبه موضوع:
  • 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
مشکل در اجرای yii2
#1
درود
وقتی میخوام صفحه اصلی یی رو بالا بیارم بهم ارور میده
Warning: require(C:\xampp\htdocs\advanced\frontend\web/../../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\advanced\frontend\web\index.php on line 5

Fatal error: require(): Failed opening required 'C:\xampp\htdocs\advanced\frontend\web/../../vendor/autoload.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\advanced\frontend\web\index.php on line 5

لطفا راهنمایی کنید
پاسخ
تشکر شده توسط:
#2
پروژه کامل ایجاد نشده. از روی فایل فشرده ایجاد کنید اگه با کامپوزر مشکل داشتین.
پاسخ
تشکر شده توسط:
#3
ممنون که پاسخ دادین من فایل فشرده رو دانلود کردم و در htdocs قرار دادم به cmd رفتم و در مسیری که یی بود دستور
composer create-project --prefer-dist --stability=dev yiisoft/yii2-app-advanced newapp رو زدم ولی باز همون ارور بالا رو میده
Warning: require(C:\xampp\htdocs\yii\newapp\frontend\web/../../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\yii\newapp\frontend\web\index.php on line 5

Fatal error: require(): Failed opening required 'C:\xampp\htdocs\yii\newapp\frontend\web/../../vendor/autoload.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\yii\newapp\frontend\web\index.php on line 5
پاسخ
تشکر شده توسط:
#4
init رو اجرا کردین؟ توی معماری advanced باید اول init رو اجرا کنید.
پاسخ
تشکر شده توسط:
#5
بله اجرا کردم!
پاسخ
تشکر شده توسط:
#6
چک کنید فایل autoload.php توی مسیر C:\xampp\htdocs\yii\newapp\vendor وجود داره یا نه. اگه از لینوکس استفاده میکنید، سطح دسترسی رو هم بررسی کنید. باید کاربر آپاچی (معمولاً www-data) بهش دسترسی داشته باشه. البته از نوع آدرسها مشخصه که از ویندوز استفاده میکنید و مشکل سطح دسترسی وجود نداره. فقط چک کنید فایل توی مسیری که گفتم موجوده یا نه و اگه نبود، مجدداً باید برنامه رو نصب کنید.
پاسخ
تشکر شده توسط:
#7
وقتی میخوام افزونه Asset رو نصب کنم ارور میده
نقل قول:
Fatal error: Call to undefined method Fxp\Composer\AssetPlugin\Package\Version\VersionParser::parseLinks() in C:\Users\hosein\Ap
ckageFilter.php on line 272
پاسخ
تشکر شده توسط:
#8
مربوط به نسخه کامپوزر هست. به یک نسخه عقبتر برگردونید.
پاسخ
تشکر شده توسط:




کاربران در حال بازدید این موضوع: 1 مهمان