رتبه موضوع:
  • 0 رای - 0 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
مشکل با jui widget (حل شد)
#1
سلام
چطوری میتونم jui widget  رو دانلود کنم؟ با کامپوزر متاسفانه بلد نیستم و از اول هم yii basic  رو دانلود کردم...

من از گیت هاب دانلودش کردم و توی مسیر vendor\yiisoft قرارش دادم به اسم yii2-jui
و توی coposer.json  رو هم تغییر دادم ولی همچنان اررور میده که کلاس datepicker  رو نمیشناسه

از اینجا هم دانلود میکنم

https://github.com/yiisoft/yii2-jui

و   composer.json :
 
    "require": {
        "php": ">=5.4.0",
        "yiisoft/yii2": ">=2.0.5",
        "yiisoft/yii2-bootstrap": "*",
        "yiisoft/yii2-swiftmailer": "*",
        "yiisoft/yii2": "~2.0.4",
        "bower-asset/jquery-ui": "1.11.*@stable",
        "yiisoft/yii2-jui": "*"
    },
پاسخ
تشکر شده توسط:
#2
توی پوشه پروژه توی خط فرمان این دستور رو بنویسید:
composer require yiisoft/yii2-jui
پاسخ
تشکر شده توسط:
#3
اگه دستی فایل composer.json رو اصلاح کردین، بعدش باید توی مسیر پروژه در خط فرمان این کد رو اجرا کنید:
composer update
پاسخ
تشکر شده توسط:
#4
یعنی فایل  yii.bat  رو اجرا کنم؟ تا بازش میکنم سریع بسته میشه
پاسخ
تشکر شده توسط:
#5
خیر. توی ویندوز دکمه Win+R رو بزنید یا از منوی Start گزینه Run رو انتخاب کنید و بنویسید CMD و بعد Enter بزنید. بعد دستورات زیر رو اجرا کنید:
C:
cd \xampp\htdocs\project
composer update

من فرض کردم پروژه در مسیر C:\xampp\htdocs\project قرار داره.
پاسخ
تشکر شده توسط:
#6
دقیقا همینکارو کردم ولی composer  رو نمیشناسه
[عکس: y97b_composer.png]
پاسخ
تشکر شده توسط:
#7
باید کامپوزر رو از https://getcomposer.org دریافت و نصب کنید.
پاسخ
تشکر شده توسط:
#8
اوکی... ولی باز موقعی که دستور رو میخوام اجرا کنم پیام میده
نقل قول:
installation failed reverting ./composer.json to its original content
 فایل composer.json  رو برگردوندم به قبلش ولی بازم این اررور رو میده
فایل composer.json  از پوشه basic  رو هم جایگزینش کردم منتها باز اررور میده باید چطوری به original  برگردونم؟
خیلی ممنون از وقتی که میگذارید
پاسخ
تشکر شده توسط:
#9
توی نت این اررور رو چک کردم و
http://stackoverflow.com/questions/27703...all-kartik

بعدش این دستور رو اجرا کردم


composer global require "fxp/composer-asset-plugin:1.0.0-beta4"

ولی این اررور رو میده...
[عکس: tshs_comp2.png]

فایل composer.json  رو کلا از تو پوشه پروژه برداشتم ولی بازم اجرا کردم این اررور رو میده
پاسخ
تشکر شده توسط:
#10
هیچ ربطی به Kartik نداره. پروژه رو طبق این راهنما ایجاد کنید: http://www.yiiframework.com/download
پاسخ
تشکر شده توسط:




کاربران در حال بازدید این موضوع: 1 مهمان